logo
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Logic Interface with FLDIGI
ke4uw
#1 Posted : Thursday, March 10, 2022 2:23:09 PM(UTC)
Rank: Member

Groups: Registered
Posts: 18
Location: Marietta, GA

Was thanked: 8 time(s) in 7 post(s)
I am trying rather unsuccessfully to get FLDIGI set up with Logic. The instructions in the Logic Help menu look simple enough, however . . .

The Logic Help page for FLDIGI setup talks about clicking Configure/Rig Control/XML-RPC. I see the configure settings in FLDIGI, and the Rig Control menu, but under the Rig Control sub-menu there is no sub-menu item for XML-RPC (FLDIGI version 4.1.20, downloaded today). None of the other rig control sub-menus have a check box for "Use XML-RPC Program" that the Logic instructions say I need to checkmark. So I can't seem to get past step one of the Logic Help instructions.

Dave KE4UW
Sponsor
Note: We receive a commission from Amazon when you purchase via this link. It does not affect your cost. Thank you!
WN4AZY
#2 Posted : Thursday, March 10, 2022 10:41:26 PM(UTC)
admin

Rank: Administration

Groups: Administrators, Beta Testers
Posts: 2,825
Man
Location: Auburn, GA

Thanks: 810 times
Was thanked: 435 time(s) in 354 post(s)
Hi Dave:

What happens if you skip that step? Just pretend you checked it hihi.

Tnx & 73,

Dennis WN4AZY
ke4uw
#3 Posted : Friday, March 11, 2022 10:25:04 AM(UTC)
Rank: Member

Groups: Registered
Posts: 18
Location: Marietta, GA

Was thanked: 8 time(s) in 7 post(s)
Well, with CAT settings enabled, FLDIGI works as it should, but with no connection to Logic. Without CAT set up in FLDIGI, no PTT, frequency display in FLDIGI isn’t updated, and I get error messages if I try to open the FLDIGI window that crash Logic.
WN4AZY
#4 Posted : Wednesday, March 23, 2022 6:09:09 PM(UTC)
admin

Rank: Administration

Groups: Administrators, Beta Testers
Posts: 2,825
Man
Location: Auburn, GA

Thanks: 810 times
Was thanked: 435 time(s) in 354 post(s)
Sorry for the delay in getting back to you.

I would ask them what the ramifications are with "Use XML-RPC Program" being gone.

I see it is still listed in their documentation:
http://mail.w1hkj.com/Fl...mlrpc_control_page.html

See also http://mail.w1hkj.com/Fl...lp/rig_config_page.html
See under "External program XmlRpc control"

Let me know.

Tnx & 73,

Dennis WN4AZY

WN4AZY
#5 Posted : Wednesday, March 23, 2022 8:28:38 PM(UTC)
admin

Rank: Administration

Groups: Administrators, Beta Testers
Posts: 2,825
Man
Location: Auburn, GA

Thanks: 810 times
Was thanked: 435 time(s) in 354 post(s)
Ok, I played around with it. It seems XML-RPC is on by default. in FLDIGI, go to Configure/Config Dialog/Misc/TCP-IP sessions. The XML line should have 127.0.0.1 for the address and 7362 for the port. If it is not set up this way, uncheck LOCK and click the DEFAULT button for XML. Save your config and restart fldigi. The Restart button does not seem to work.

Now run LOGic. Whatever you type in the transmit window shows up in fldigi.

Get LOGic and fldigi working without the rig first. You may have to unblock 127.0.0.1:7632 in your firewall.

When it comes time to connect the rig, connect it to LOGic as usual. Do not attempt to interface the rig to fldigi.

Make sure fldigi is running before starting LOGic, and do not close fldigi without closing LOGic first.

Hope this helps. Let me know.

Tnx & 73,

Dennis WN4AZY
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF 1.9.5.5 | YAF © 2003-2011, Yet Another Forum.NET
This page was generated in 0.039 seconds.