logo
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Error while setting GMail SMTP integration into Logic
K7PDW
#1 Posted : Thursday, November 22, 2018 3:42:21 PM(UTC)
DAVE

Rank: Advanced Member

Groups: Registered
Posts: 61
Location: Syracuse, Utah

Thanks: 11 times
Was thanked: 8 time(s) in 8 post(s)
When I was attempting to set up "Send Email Setup" from Spot Log->Email Setup I ran into an issue.
I first enabled POP in my GMail settings, and entered the SMTP address (smtp.gmail.com) into LOGic. I then tested with and without appending the port (specified in Google's documentation: https://support.google.com/mail/answer/7104828)
I entered in both my username (GMail Address), password (GMail Password), enabled SSL, entered in both the sender and recipient addresses, and hit send, upon which I was greeted with the error message:

"Test email message not sent. An error occured:
The transport failed to connect to the server.
Check your server name or address."

I thought perhaps my password was incorrect so I verified it was indeed correct and retested, still to no avail. So my question is, is this an issue with how LOGic handles SMTP requests? Or an issue with GMail not reading LOGic's request properly?

Thanks.
Sponsor
WN4AZY
#2 Posted : Friday, November 23, 2018 9:21:25 AM(UTC)
admin

Rank: Administration

Groups: Administrators, Beta Testers
Posts: 2,213
Man
Location: Auburn, GA

Thanks: 403 times
Was thanked: 298 time(s) in 236 post(s)
Ok, first of all, based on that error, I think you are forgetting the port after the server or forgetting to select SSL. So in LOGic, enter the server as

smtp.gmail.com:465

and make sure SSL is on.

Enter your password. Set the Username and the From Address to your Gmail address. Enter your email address in To Address. It can be your Gmail address or another address.

Go to https://myaccount.google.com/lesssecureapps and turn Less Secure Apps on.

It should work now!

For anyone who cares to read about the particulars of how I discovered this, or the above does not work for you, read on.

I entered the stuff in LOGic as described above, but then I got error in LOGic saying:

Quote:
The message could not sent to the SMTP server. The transport error code was 0x80040217. The server response is not available.


But I got an email in my Gmail account with the subject of Critical Security Alert. The email said "Someone just used your password to try to sign in to your account from a non-Google app. Google blocked them, but you should check what happened. Review your account activity to make sure no one else has access."

I followed the link on the email to CHECK ACTIVITY. The web page asked "Were you recently prevented from signing into your Google Account?" The options are NO, SECURE ACCOUNT, and YES. I clicked YES. I was taken to another screen entitled "Less secure app blocked." I clicked "Learn more." There is a link saying "Go to the Less secure apps section." I clicked it. I turned on Less secure app access. However, LOGic still did not work. I discovered that the link to enable Less Secure Apps had me logged into the wrong Google account (I have seceral). I logged into the right account, went to https://myaccount.google.com/lesssecureapps, turned Less Secure Apps on, and tada!


Tnx & 73,


Dennis WN4AZY
K7PDW
#3 Posted : Friday, November 23, 2018 5:23:46 PM(UTC)
DAVE

Rank: Advanced Member

Groups: Registered
Posts: 61
Location: Syracuse, Utah

Thanks: 11 times
Was thanked: 8 time(s) in 8 post(s)
Okay, after enabling "Less Secure Apps" from within my Google Account settings it now sent successfully! Thank you for your help.
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF 1.9.5.5 | YAF © 2003-2011, Yet Another Forum.NET
This page was generated in 0.049 seconds.