Welcome Guest! To enable all features please Login or Register.



Error while setting GMail SMTP integration into Logic
#1 Posted : Thursday, November 22, 2018 3:42:21 PM(UTC)

Rank: Advanced Member

Groups: Registered
Posts: 73
Location: Syracuse, Utah

Thanks: 15 times
Was thanked: 11 time(s) in 11 post(s)
When I was attempting to set up "Send Email Setup" from Spot Log->Email Setup I ran into an issue.
I first enabled POP in my GMail settings, and entered the SMTP address (smtp.gmail.com) into LOGic. I then tested with and without appending the port (specified in Google's documentation: https://support.google.com/mail/answer/7104828)
I entered in both my username (GMail Address), password (GMail Password), enabled SSL, entered in both the sender and recipient addresses, and hit send, upon which I was greeted with the error message:

"Test email message not sent. An error occured:
The transport failed to connect to the server.
Check your server name or address."

I thought perhaps my password was incorrect so I verified it was indeed correct and retested, still to no avail. So my question is, is this an issue with how LOGic handles SMTP requests? Or an issue with GMail not reading LOGic's request properly?

Note: We receive a commission from Amazon when you purchase via this link. It does not affect your cost. Thank you!
#2 Posted : Friday, November 23, 2018 9:21:25 AM(UTC)

Rank: Administration

Groups: Administrators, Beta Testers
Posts: 2,424
Location: Auburn, GA

Thanks: 534 times
Was thanked: 354 time(s) in 279 post(s)
Ok, first of all, based on that error, I think you are forgetting the port after the server or forgetting to select SSL. So in LOGic, enter the server as


and make sure SSL is on.

Enter your password. Set the Username and the From Address to your Gmail address. Enter your email address in To Address. It can be your Gmail address or another address.

Go to https://myaccount.google.com/lesssecureapps and turn Less Secure Apps on.

It should work now!

For anyone who cares to read about the particulars of how I discovered this, or the above does not work for you, read on.

I entered the stuff in LOGic as described above, but then I got error in LOGic saying:

The message could not sent to the SMTP server. The transport error code was 0x80040217. The server response is not available.

But I got an email in my Gmail account with the subject of Critical Security Alert. The email said "Someone just used your password to try to sign in to your account from a non-Google app. Google blocked them, but you should check what happened. Review your account activity to make sure no one else has access."

I followed the link on the email to CHECK ACTIVITY. The web page asked "Were you recently prevented from signing into your Google Account?" The options are NO, SECURE ACCOUNT, and YES. I clicked YES. I was taken to another screen entitled "Less secure app blocked." I clicked "Learn more." There is a link saying "Go to the Less secure apps section." I clicked it. I turned on Less secure app access. However, LOGic still did not work. I discovered that the link to enable Less Secure Apps had me logged into the wrong Google account (I have seceral). I logged into the right account, went to https://myaccount.google.com/lesssecureapps, turned Less Secure Apps on, and tada!

Tnx & 73,

Dennis WN4AZY
#4 Posted : Friday, November 23, 2018 5:23:46 PM(UTC)

Rank: Advanced Member

Groups: Registered
Posts: 73
Location: Syracuse, Utah

Thanks: 15 times
Was thanked: 11 time(s) in 11 post(s)
Okay, after enabling "Less Secure Apps" from within my Google Account settings it now sent successfully! Thank you for your help.
#6 Posted : Tuesday, April 16, 2019 8:20:53 AM(UTC)

Rank: Advanced Member

Groups: Registered
Posts: 73
Location: Syracuse, Utah

Thanks: 15 times
Was thanked: 11 time(s) in 11 post(s)
HEADS UP! - After not using the email alert for several weeks, I got the same error when I tried to use it again. It turned out the Google security settings were set back to the highest level. Apparently when I updated Chrome, it set my security setting back to the higher level. I changed the security level back down and it works again. Thought you'd like to know.
1 user thanked K7PDW for this useful post.
WN4AZY on 4/17/2019(UTC)
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF | YAF © 2003-2011, Yet Another Forum.NET
This page was generated in 0.041 seconds.